Welcome!

This community is for professionals and enthusiasts of our products and services. Share and discuss the best content and new marketing ideas, build your professional profile and become a better marketer together.

0

Modubus TCP Slave Library Issue

By
Guest
on 9/14/20, 4:42 AM 14 views

I copied from GitHub the following sketch but the Arduino IDE debugger says that the library ModbusTCPSlave.h does not exist anymore.

\https://github.com/IndustrialShields/arduino-Tools40/blob/master/examples/Modbus/ModbusTCPSlave/ModbusTCPSlave.ino

Is there an updated version or equivalent that I am missing?


0
Industrial Shields Forum user

Guillem Cura Marti

--Guillem Cura Marti--

1000000005
| 0 0 0
Sant Fruitós de Bages, España
--Guillem Cura Marti--
Guillem Cura Marti
On 9/14/20, 5:53 AM

Yes, it exists. In order to use it you need to download the Tools40 library from the github. Download the zip file from the following link and include it on you arduino IDE libraries

https://github.com/IndustrialShields/arduino-Tools40

You can also check out our blog about the first steps using our Arduino based PLC's to know how to install all the requiered libraries and our boards:

https://www.industrialshields.com/first-steps-with-the-industrial-arduino-based-plc-s-and-the-panel-pc-s-raspberry-pi-based
 
I hope i have helped

Keep Informed

About This Community

This community is for professionals and enthusiasts of our products and services. Share and discuss the best content and new marketing ideas, build your professional profile and become a better marketer together. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 9/14/20, 4:42 AM
Seen: 14 times
Last updated: 9/14/20, 5:53 AM