Según altos estándares industriales

Welcome!

This community is for professionals and enthusiasts of our products and services. Share and discuss the best content and new marketing ideas, build your professional profile and become a better marketer together.

0

Timout programming MDuino

por
Danny Ng
en 6/2/20 20:17 307 vistas

I just gotten my industrial shield. However I am facing issue programming the Arudino.

Getting avrdude: stk500v2_ReceiveMessage(): timeout

Anyone else face this before?


0
Industrial Shields Forum user

Andrei Postolache

--Andrei Postolache--

2000000000
| 0 0 0
--Andrei Postolache--
Andrei Postolache
En 18/6/20 5:06

Hello Danny,

There could be one of the four possible reason behind it. They are:

  1. Wrong Port Selected:

    If TX/RX led is not blinking, then you may have selected wrong port. If one of both of them are blinking then, you aren't using the wrong port. It might be worth checking again though, sometimes USB COM devices install on strange port numbers.

  2. Board is not in Bootloader Mode:

    The Arduino Mega is not executing the bootloader for some reason. If the programmer is not resetting the micro before attempting to connect, this might be the reason. Try to reset the board (press and release the button) while the programmer is attempting to connect. Sometimes software that runs in a tight loop will prevent the bootloader from connecting. Barring that, the fuses might have gotten messed up or the code erased. You would need to reflash the bootloader and proper fuses, again, see the appropriate info page for your device.

  3. Arduino Mega 2560 only: ATmega8U/16U software

    Might not be working and would need reprogramming. See the Programming section on the info page, you will need the firmware and Atmel-compatible DFU (device firmware update) software on your computer toreflash the target.

  4. Hardware damage:

    There could be hardware damage to the board, AVR(s), or FTDI chip.

You can contact us on the Technical Support email or Whatsapp.

Thank you.

  • Marcar

Manage to get the issue sorted out when I submitted a ticket on this. Following guide I get from the ticket, I plan to change the Arduino unit. However the unit work fine after I have taken out the Arduino and notice that the Arduino can be programmed so I did not change the Arduino and assemble the unit again.

After reassembling the unit and I notice that It can work. I think it might be due to shipping causing some part to went loose.

Got it sorted out at the end.

Danny Ng
de 18/6/20 5:25

Mantener informado

Acerca de esta comunidad

Esta comunidad es para profesionales y entusiastas de nuestros productos y servicios, compartir los mejores contenidos y nuevas ideas de marketing, construir su perfil profesional y mejorar el mercado para todos. Lea los lineamientos

Herramientas de las preguntas

8 seguidor(es)

Estadísticas

Preguntado: 6/2/20 20:17
Visto: 307 veces
Última actualización: 18/6/20 5:06